Pages: [1]
Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 10,149,942,176
World-rank: 279

2015-05-23 17:24:39
last modified: 2015-05-23 17:29:17

I can't tell if this would be considered a BAM! or BS bug, or a "new" project but here we go...

For the last week or so, http://volunteer.cs.und.edu/csg/ said:

We're changing the Citizen Science Grid

We're moving CSG from "volunteer.cs.und.edu" to "csgrid.org". Please be patient while we make this change.

We expect to have the Citizen Science Grid back online this weekend, please check back on Monday, May 25th.

Today I noticed in the event log:

5/23/2015 10:15:43 AM | Citizen Science Grid | You used the wrong URL for this project. When convenient, remove this project, then add http://csgrid.org/csg/

So, they actually seem to have finished the switch faster than their schedule.

I first did a Delayed Detach on BAM! for CSG for all my hosts and force-sync'd my hosts, which drained & reset & detached from CSG on my hosts. But, when I used BAM! to Attach the projects back to every host, and force-sync my hosts, they all connected back to the old URL.

So, obviously the URL needs to be fixed. I put all my hosts back into the Delayed Detach mode awaiting the draining of the few tasks they got from the old URL during the latest Attach, and also waiting for BS/BAM! to start using the new URL before attempting again to re-Attach them afterwards.

Thanks!
Tuna

[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9155
Credits: 348,857,342
World-rank: 3,151

2015-05-24 07:08:29

BAM! will update the project automatically.
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 10,149,942,176
World-rank: 279

2015-05-24 08:17:54

Did you change it to http://csgrid.org/csg/ or http://csgrid.org? It should be http://csgrid.org/csg/. I am asking because I am seeing:

5/24/2015 1:11:38 AM | http://csgrid.org/ | [error] No scheduler URLs found in master file

I don't know if it matters or if their new server's master file is lacking... Just thought I'd raise the issue.

Tuna
MB Atlanos
  Donator
BAM!ID: 910
Joined: 2006-05-28
Posts: 21
Credits: 4,800,700
World-rank: 71,194

2015-05-24 12:43:21
last modified: 2015-05-24 12:43:55

I get this error too:
Sun 24 May 14:32:18 2015 | | Attaching to http://csgrid.org/
Sun 24 May 14:32:21 2015 | http://csgrid.org/ | [error] No scheduler URLs found in master file

Code:
Volunteer Computing (BOINC) Instructions

If you're already running BOINC, select Attach to Project. If not, download, install and run BOINC.
When prompted, enter http://csgrid.org/csg/
If you're running a command-line or pre-5.0 version of BOINC, create an account first.
If you have any problems, get help here.

from http://csgrid.org/csg/instructions.php
Since no one on the CSG forum is complaining, the master file should be in place.

Willy, please correct the URL.
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9155
Credits: 348,857,342
World-rank: 3,151

2015-05-24 16:54:05

URL corrected
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
MB Atlanos
  Donator
BAM!ID: 910
Joined: 2006-05-28
Posts: 21
Credits: 4,800,700
World-rank: 71,194

2015-05-24 18:23:03
last modified: 2015-05-24 18:31:53

Wonderfull, thanks Willy.

But after a sync with BAM! http://csgrid.org/ stuck als a separate project in my BOINC manager. Looks like there was no auto-detach for the wrong URL, just a attach for the right URL:
Code:
Sun 24 May 20:13:15 2015 | | Account manager contact succeeded
Sun 24 May 20:13:15 2015 | | Attaching to http://csgrid.org/csg/
Sun 24 May 20:13:20 2015 | http://csgrid.org/csg/ | Master file download succeeded
Sun 24 May 20:13:25 2015 | http://csgrid.org/csg/ | Sending scheduler request: Project initialization.

Manual intervention wih de-/reattach of CSG for this host affects only the right URL.
Could you please fix this?
Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 10,149,942,176
World-rank: 279

2015-05-24 19:07:25

Yup, confirmed that this is the case. I now have one right and one wrong entry in BOINC manager for CSG on all my machines I looked at. Since the wrong one is also managed by BAM!, one cannot remove it manually through the BOINC Manager UI. I suspect some manual work will need to happen on the local XML files to get rid of the bad one. Willy, do you know what to change in which local file(s) under the BOINC data folder, or is there something you can do on BAM! side?

Thanks!
Tuna
Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 10,149,942,176
World-rank: 279

2015-05-25 04:08:26

Here is what worked for me. Use at your own risk...

- File/Exit BOINC Manager. Not minimize, not just close, but really exit with all task processing stopped, nothing left running in the background.
- Go to the BOINC data folder
- Delete csgrid.org folder
- Delete master_csgrid.org.xml file
- Delete account_csgrid.org.xml file
- Edit (using Notepad on Windows) acct_mgr_request.xml, remove the section about csgrid.org that looks like this:

<project>
<url>http://csgrid.org/</url>
<project_name></project_name>
<suspended_via_gui>0</suspended_via_gui>
<account_key>blah blah blah</account_key>
<hostid>0</hostid>
<not_started_dur>0.000000</not_started_dur>
<in_progress_dur>0.000000</in_progress_dur>
<attached_via_acct_mgr>1</attached_via_acct_mgr>
<dont_request_more_work>0</dont_request_more_work>
<detach_when_done>0</detach_when_done>
<ended>0</ended>
<resource_share>100.000000</resource_share>
</project>

- Restart BOINC
- Force an update with BAM!

As I said, this worked for me. Not all of this might be needed, but this worked.

Good luck!
Tuna
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9155
Credits: 348,857,342
World-rank: 3,151

2015-05-25 07:17:19

csgrid.org/ was correctly added to the "retired" urls. What does your message log show? Is csgrid.org/ listed in acct_mgr_request.xml and does acct_mgr_reply.xml have a detach section for csgrid.org/?
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 10,149,942,176
World-rank: 279

2015-05-25 09:11:13
last modified: 2015-05-25 09:16:41

Too late for me to provide any useful answers; others who haven't done what I did should respond.

When I did my steps, acct_mgr_request.xml on every one of my 8 hosts had a csgrid.org section. I manually removed them, along with the project folder and the XML files, and never looked into the acct_mgr_reply.xml to see if there was any detach section (frankly, I didn't know to look for it). I probably did all this before you added it to the retired URLs. If you think I did it after you "retired" the bad URL, well, then I don't know why every one of my hosts still had it showing as a BAM!-managed project that just wouldn't go away, with the section still in the acct_mgr_request.xml left behind even though my hosts sync with BAM! every 60mins.

Looking at stdoutdae.txt, there were no detach requests for csgrid.org, even after the correct URL was attached to:

****** I set CSG to drain and detach on all my hosts via BAM!, and the hosts get the news via my hourly BAM! sync
23-May-2015 10:15:43 [Citizen Science Grid] You used the wrong URL for this project. When convenient, remove this project, then add http://csgrid.org/csg/
****** some more interspersed lines about CSG tasks starting/finishing/reporting...
23-May-2015 12:50:25 [Citizen Science Grid] Reporting 1 completed tasks
23-May-2015 12:50:25 [Citizen Science Grid] Not requesting tasks: "no new tasks" requested via Manager
23-May-2015 12:50:26 [Citizen Science Grid] Scheduler request completed
23-May-2015 12:50:26 [Citizen Science Grid] You used the wrong URL for this project. When convenient, remove this project, then add http://csgrid.org/csg/
23-May-2015 12:50:28 [Citizen Science Grid] Resetting project
23-May-2015 12:50:28 [Citizen Science Grid] Detaching from project
24-May-2015 01:11:13 [---] Attaching to http://csgrid.org/
24-May-2015 01:11:16 [http://csgrid.org/] No scheduler URLs found in master file
24-May-2015 01:11:36 [http://csgrid.org/] update requested by user
24-May-2015 01:11:38 [http://csgrid.org/] No scheduler URLs found in master file
24-May-2015 04:01:19 [http://csgrid.org/] No scheduler URLs found in master file
24-May-2015 10:12:03 [---] Attaching to http://csgrid.org/csg/
24-May-2015 10:12:07 [http://csgrid.org/csg/] Master file download succeeded
24-May-2015 10:12:12 [http://csgrid.org/csg/] Sending scheduler request: Project initialization.
24-May-2015 10:12:12 [http://csgrid.org/csg/] Requesting new tasks for CPU and NVIDIA GPU
24-May-2015 10:12:14 [---] [unparsed_xml] WORKUNIT:: parse(): unrecognized: seed
24-May-2015 10:12:14 [---] [unparsed_xml] WORKUNIT:: parse(): unrecognized: sampler_id
24-May-2015 10:12:14 [---] [unparsed_xml] WORKUNIT:: parse(): unrecognized: walk_id
24-May-2015 10:12:14 [---] [unparsed_xml] WORKUNIT:: parse(): unrecognized: current_steps
24-May-2015 10:12:14 [Citizen Science Grid] Scheduler request completed: got 1 new tasks
******* At 24-May-2015 21:18 I did my steps and restarted BOINC
24-May-2015 21:19:54 [http://csgrid.org/] Project http://csgrid.org/ is in state file but no account file found
24-May-2015 21:19:54 [Citizen Science Grid] URL http://csgrid.org/csg/; Computer ID 8048; resource share 100

And, a line is still in my all_projects_list.xml: <url>http://csgrid.org</url> I'll probably remove them in the morning.

So, that is it. There were no detach requests for csgrid.org after csgrid.org/csg was added even though between 24-May-2015 10:12:03 (when the good URL was added) and 21:00 (when I did my manual steps) there must have been 10-12 BAM! updates on this one host alone. But, none of my 8 hosts were detached from the bad URL around 21:00.

My times are -7hrs of your server time, by the way. So, my manual steps done at 24-May-2015 21:18 was 25-May-2015 04:18 for you.

And, it is 2:10am my time, so g'nite!

Tuna
MB Atlanos
  Donator
BAM!ID: 910
Joined: 2006-05-28
Posts: 21
Credits: 4,800,700
World-rank: 71,194

2015-05-25 20:33:35

Today the wrong project was removed via regular BAM!-contact:
Code:
Mon 25 May 13:51:54 2015 | http://bam.boincstats.com/ | Account manager RPC failed: can't resolve hostname
Mon 25 May 14:00:36 2015 | | Contacting account manager at http://bam.boincstats.com/
Mon 25 May 14:00:37 2015 | | Account manager: BAM! User: 910, MB Atlanos
Mon 25 May 14:00:37 2015 | | Account manager: BAM! Host: ######
Mon 25 May 14:00:37 2015 | | Account manager: Number of BAM! connections for this host: 1160
Mon 25 May 14:00:37 2015 | | Account manager: Delayed detach from Citizen Science Grid, project changed URL. After detaching project will reattach with new URL on next communication!
Mon 25 May 14:00:37 2015 | | Account manager contact succeeded
Mon 25 May 14:00:47 2015 | http://csgrid.org/ | Resetting project
Mon 25 May 14:00:47 2015 | http://csgrid.org/ | Detaching from project
Yesterdays manual BAM!-contact requests are unsuccessfull, i guess it just needed some time.
As expected there are no csgrid.org/ listed in acct_mgr_request.xml or acct_mgr_reply.xml, but these files are from 22:00, so it was from the next BAM!-contact.
Pages: [1]

Index :: BAM! Bug Report :: CSG changed URLs
Reason: