Pages: [1]
Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 9,546,099,055
World-rank: 273

2016-01-26 22:32:53

I don't know if this is now a general problem after the recent server software upgrades or specific to the circumstances, but...

BealF and EDGeS were retired recently. But, the projects had stopped responding a while ago. Between when they stopped responding and when they were retired here, any new hosts I brought online received them from BAM! as part of the "Attach new host by default? = Yes" setting. So, they were added to these hosts as "Added via acct mgr=yes", but never got any actual connection to the projects, so stayed as the URL in the Project column. Then they got retired in BOINCstats, rightfully. Yet, they did not get automatically removed from these clients even though I have "Detach retired projects from hosts=Yes". And, when I go to these hosts, BOINCMgr won't let me "Remove" them, since they are added by an acct mgr.

What to do? Do I have to go into the misc XML files to surgically remove them and remove the project folders?

Thanks
Tuna

PS: Also, the projects were not removed from the hosts where they were added BEFORE the host was under BAM! management, presumably since they were not marked as "Added via acct mgr=yes", just like the rest of the projects on such hosts, even though BAM! successfully manages them. I don't know if that is by design or a bug. Luckily, BOINCMgr lets you "Remove" them manually.

Thanks
Tuna

Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 9,546,099,055
World-rank: 273

2016-01-26 22:35:54

Oh, wait. I just found a host where BealF and EDGeS were added by BAM! when the projects were responding, thus the project names are all correct (instead of URLs), and they are marked as "Added via acct mgr=yes", and they were *not* removed as part of the retirement, and they cannot be removed with the (disabled) "Remove" button in BOINCMgr.

So, this might actually be a general issue with "Detach retired projects from hosts=Yes" not working after the software updates.
Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 9,546,099,055
World-rank: 273

2016-01-26 22:55:21
last modified: 2016-01-26 23:30:00

And, found another host still with a connection to Constellation which was retired a while ago (2015-11-18, certainly before server upgrades), and SLinCA (2015-09-06). But on this host, both weren't marked with "Added via acct mgr=yes", so maybe they weren't supposed to be detached by BAM!, which is sort of a bummer. I removed them manually.

Sorry, walking around the house, hunting down my hosts is taking time...
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9136
Credits: 348,241,820
World-rank: 2,969

2016-01-27 07:32:08

Please check the acct_mgr_reply if there is a detach command for these projects.

The BAM! code has not been changed so this should still work properly. There is also a counter how many detach commands have been send to a retired project which for Edges and Bealf is at 2629 and 155 respectively.
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 9,546,099,055
World-rank: 273

2016-01-27 07:43:07

On the host I am sitting in front of (https://boincstats.com/en/bam/host/568110), the acct_mgr_reply.xml has nothing related to either project. It only has the following:


<acct_mgr_reply>
<name>BOINCstatsBAM!</name>
<version>2.2.8</version>
<server>www2</server>
<signing_key> 1024
blahblahblah.
</signing_key>
<message>
<![CDATA[BAM! User: 37744, Tuna Ertemalp]]>
</message>
<message>BAM! Host: 568110</message>
<message>Number of BAM! connections for this host: 6339</message>
<message>
<![CDATA[Dear founder of team Microsoft, your team is invited to participate in
the team challenges (http://boincstats.com/en/bam/teamChallenge/)]]>
</message>
<repeat_sec>3600</repeat_sec>
<global_preferences>
<host_specific/>
<source_project>http://bam.boincstats.com/</source_project>
<mod_time>1453786849</mod_time>
<run_if_user_active>0</run_if_user_active>
<run_gpu_if_user_active>0</run_gpu_if_user_active>
<suspend_if_no_recent_input>0</suspend_if_no_recent_input>
<cpu_scheduling_period_minutes>60</cpu_scheduling_period_minutes>
<idle_time_to_run>3</idle_time_to_run>
<work_buf_min_days>1</work_buf_min_days>
<work_buf_additional_days>5</work_buf_additional_days>
<max_cpus>1024</max_cpus>
<max_ncpus_pct>100</max_ncpus_pct>
<suspend_cpu_usage>25</suspend_cpu_usage>
<cpu_usage_limit>100</cpu_usage_limit>
<disk_interval>60</disk_interval>
<disk_max_used_gb>50</disk_max_used_gb>
<disk_max_used_pct>40</disk_max_used_pct>
<disk_min_free_gb>5</disk_min_free_gb>
<vm_max_used_pct>75</vm_max_used_pct>
<ram_max_used_busy_pct>20</ram_max_used_busy_pct>
<ram_max_used_idle_pct>90</ram_max_used_idle_pct>
<max_bytes_sec_down>0</max_bytes_sec_down>
<max_bytes_sec_up>0</max_bytes_sec_up>
<start_hour>0</start_hour>
<end_hour>0</end_hour>
<net_start_hour>0</net_start_hour>
<net_end_hour>0</net_end_hour>
</global_preferences>
<host_venue/>
<opaque>
<host_authenticator> blah blah blah </host_authenticator>
</opaque>
</acct_mgr_reply>


All of my machines installed before these projects have been retired still have these projects connected. Plus that one machine that still had Constellation and SLinCA. Something is wrong...

Tuna
Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 9,546,099,055
World-rank: 273

2016-01-27 07:49:31

Reran a BAMsync, this time the reply came from www1, the only difference is "Number of BAM! connections for this host: 6336" which is 3 less than what www2 said. Huh?
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9136
Credits: 348,241,820
World-rank: 2,969

2016-01-27 08:10:58

Enabled debugging for this host id so I can see all xml received and send.
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 9,546,099,055
World-rank: 273

2016-01-27 08:30:21

Just did a fresh sync, in case you wanted to look at your debugging data.
Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 9,546,099,055
World-rank: 273

2016-01-27 08:34:55

If that doesn't help, you might want to turn on debugging for all my hosts. They sync every hour and I think almost all have this problem. I am about to head to bed. It is 00:34 here...
Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 9,546,099,055
World-rank: 273

2016-01-27 17:49:20

Was that helpful while I was sleeping, or would you need the hostIDs of all my hosts that are not getting Detach commands from BAM!?
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9136
Credits: 348,241,820
World-rank: 2,969

2016-01-27 18:13:09

Sorry, I had appraisals all day long. Didn't get to do anything else.
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 9,546,099,055
World-rank: 273

2016-01-27 18:45:39

No problem at all. Just let me know if you need anything from me...
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9136
Credits: 348,241,820
World-rank: 2,969

2016-01-28 08:05:02

Found your problem: on the page BAM! settings your setting "Detach retired projects from hosts" is set to 'no'.
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 9,546,099,055
World-rank: 273

2016-01-28 08:31:16

No. I had set it to yes forever ago which is why it had worked for Constellation and SLinCA, except for one machine. I looked at all my settings after the user account restore from old backup issue, and it was set to yes. And, i checked before i reported this, it was yes. I still see it as yes. Maybe web doesn't show what is in the db?
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9136
Credits: 348,241,820
World-rank: 2,969

2016-01-28 08:43:56

Database says 'no' so I have to check the web interface. Changed it to 'yes'.
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 9,546,099,055
World-rank: 273

2016-01-28 08:48:12
last modified: 2016-01-28 09:11:42

And, now I am seeing NO on the web. But, when I sync'd, two projects did get detached, correctly. So, web is showing the exact opposite of the db. Which explains it. A year ago, I wasn't using BAM!, but had an account, thus the default must have been NO. Then in April I started using it, changed it to YES. The recent restore from year old backup must have reset it to NO in the db, but some bug on the web interface kept showing YES. And, detaches didn't happen, without giving a visual clue on the web as to why not.
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9136
Credits: 348,241,820
World-rank: 2,969

2016-01-28 15:51:19

Fixed the web interface.
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
Pages: [1]

Index :: BAM! Bug Report :: Retired projects not removed automatically
Reason: