Pages: [1]
Zachary_DuBois
BAM!ID: 194119
Joined: 2015-08-26
Posts: 2
Credits: 35,767
World-rank: 1,037,289

2016-09-09 17:33:20

I am attempting to get my servers running BOINC limited at 25% CPU when they are below 50% CPU and am having quite some issues in the work preferences from BAM! syncing to it.

Version:
Code:
# boinccmd -V
boinccmd, built from BOINC 7.2.42


Screenshot of my word preferences:


Output of /var/lib/boinc-client/global_prefs.xml
Code:
<global_preferences>

<host_specific/>
<source_project>http://bam.boincstats.com/</source_project>
<mod_time>1473438897</mod_time>
<run_if_user_active>1</run_if_user_active>
<run_gpu_if_user_active>1</run_gpu_if_user_active>
<suspend_if_no_recent_input>0</suspend_if_no_recent_input>
<cpu_scheduling_period_minutes>60</cpu_scheduling_period_minutes>
<idle_time_to_run>3</idle_time_to_run>
<work_buf_min_days>0.1</work_buf_min_days>
<work_buf_additional_days>0</work_buf_additional_days>
<max_cpus>1024</max_cpus>
<max_ncpus_pct>25</max_ncpus_pct>
<suspend_cpu_usage>50</suspend_cpu_usage>
<cpu_usage_limit>100</cpu_usage_limit>
<disk_interval>60</disk_interval>
<disk_max_used_gb>5</disk_max_used_gb>
<disk_max_used_pct>50</disk_max_used_pct>
<disk_min_free_gb>1</disk_min_free_gb>
<vm_max_used_pct>50</vm_max_used_pct>
<ram_max_used_busy_pct>50</ram_max_used_busy_pct>
<ram_max_used_idle_pct>50</ram_max_used_idle_pct>
<max_bytes_sec_down>0</max_bytes_sec_down>
<max_bytes_sec_up>0</max_bytes_sec_up>
<hangup_if_dialed/>
<start_hour>0</start_hour>
<end_hour>0</end_hour>
<net_start_hour>0</net_start_hour>
<net_end_hour>0</net_end_hour>
</global_preferences>


You'll notice that everything appears to be correct in there except cpu_usage_limit which is 100% when it should be 25%. Anyone know a resolution/workaround for this issue? If I really need to use the override file, I will but I prefer to use the online preferences.
Zachary_DuBois
BAM!ID: 194119
Joined: 2015-08-26
Posts: 2
Credits: 35,767
World-rank: 1,037,289

2016-09-13 00:36:36

So, I just installed BOINC on my MacBook and it pulled the work preferences perfectly and enforced the CPU correctly proving this is a boinccmd issue and not a BAM! issue.
gemini8
BAM!ID: 101557
Joined: 2011-06-14
Posts: 35
Credits: 594,100,470
World-rank: 2,300

2016-09-16 22:04:01

Hi.
Code:

<max_cpus>1024</max_cpus>
<max_ncpus_pct>25</max_ncpus_pct>
<suspend_cpu_usage>50</suspend_cpu_usage>
<cpu_usage_limit>100</cpu_usage_limit>

If I understand this correctly you allow at most 1024 CPUs or 25% of your CPUs.
To allow all CPUs to run Boinc at 25% if the processors use max. 50% of their processing time, you need to set the suspend cpu usage to 50 (%) and the spu usage limit to 25 (%). If this may apply to all CPUs you have to set max ncpus pct to 100 (%).
- - - - - - - - - - -
Greetings, Jens
Pages: [1]

Index :: BAM! Bug Report :: Boinccmd not pulling correct work preferences from BAM!
Reason: