Pages: [1]
thuffir
BAM!ID: 2427
Joined: 2006-06-21
Posts: 4
Credits: 53,081
World-rank: 888,173

2006-06-25 16:48:27

Unfortunatelly the above function is not working for me. Every time I close my browser (IE 6) I have to re-enter my username and password.

I also tried to allow all cookies for boincstats.com. No success.

What am I doing wrong?
Son Goku 3SSJ
 
Forum moderator - Translator
BAM!ID: 8
Joined: 2006-01-11
Posts: 182
Credits: 2,572,985
World-rank: 116,626

2006-06-25 18:04:15

Unfortunatelly the above function is not working for me. Every time I close my browser (IE 6) I have to re-enter my username and password.

I also tried to allow all cookies for boincstats.com. No success.

What am I doing wrong?

I think that cookies must be enabled in order the stay logged in to work. Tried it under IE7 BETA 2 and it is working normally
part of
Wenn jeder an sich denkt, wird an alle gedacht!
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9237
Credits: 349,822,518
World-rank: 3,575

2006-06-25 18:35:28

I know of the problem, but I can't reproduce it (on any system, and I have a whole bunch of them).

I think it's a combination of OS, browser, AV and AS software, and maybe other stuff.
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
thuffir
BAM!ID: 2427
Joined: 2006-06-21
Posts: 4
Credits: 53,081
World-rank: 888,173

2006-06-25 20:52:31

I can reproduce it. Both on my home PC and my Work PC
Both of them XP + IE 6...

Okay... Thanks anyways
NJMHoffmann
BAM!ID: 377
Joined: 2006-05-14
Posts: 32
Credits: 268,145
World-rank: 414,042

2006-06-26 10:13:44

I know of the problem, but I can't reproduce it (on any system, and I have a whole bunch of them).

I think it's a combination of OS, browser, AV and AS software, and maybe other stuff.

I have this problem here consistently too. Even tried the debug page and mailed the debug info to you. Despite the info from the cookies being sent to and known by BAM [it displayed user# and password-hash(?) in the debug info], I was not connected.

Norbert
Andrew Waddington
BAM!ID: 26
Joined: 2006-02-27
Posts: 2
Credits: 98,433
World-rank: 682,603

2006-07-07 07:03:02
last modified: 2006-07-07 07:09:06

Unfortunatelly the above function is not working for me. Every time I close my browser (IE 6) I have to re-enter my username and password.

I also tried to allow all cookies for boincstats.com. No success.

What am I doing wrong?



I don't think it has anything to do with us, I have tried it on a number of windows machines with different windows versions and with and without AV programs with the same result, does not remeber me.

I will try it with firefox in the next few days when i get a moment of free time.

Just made so free time and it does not work on firefox on a win2000 machine. I think it is someting in the web pages.
Honza
BAM!ID: 109
Joined: 2006-05-10
Posts: 154
Credits: 4,038,840,189
World-rank: 569

2006-07-07 07:28:06

Happened first time to me today. The only change I can imagine is a regular NOD32 update; Opera remains the same, no Win XP updates etc.
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9237
Credits: 349,822,518
World-rank: 3,575

2006-07-07 08:43:07

I still can't find any error in my code, and I haven't encountered this on any of my systems, so debugging it is difficult.

Please do the following:

    *Close all your browser windows (to avoid influences from other opened windows)
    *Start a browser
    *Go to http://www.boincstats.com/testing/
    *Copy-Paste the debug code in the main window to this thread.

Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
Honza
BAM!ID: 109
Joined: 2006-05-10
Posts: 154
Credits: 4,038,840,189
World-rank: 569

2006-07-07 08:52:02
last modified: 2006-07-07 10:32:18

OK, done.

Debug info:
ID1:109
ID2:109
Hash:1f200c5a490d964df9d3ec844132a30e
QueryELECT * FROM boincstats_ams.users WHERE id = '109' AND hash = '1f200c5a490d964df9d3ec844132a30e' AND activated = '1'
stay_logged_in:!
Logging:
Debug:1356
End of debug info
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9237
Credits: 349,822,518
World-rank: 3,575

2006-07-07 09:32:51

I really don't get it. You should be logged in. All checks are ok, the debug path is 100% correct.
1356, 1=start, 3=cookies found, 5=succesfull login, 6=store cookies.

What is showing in the 'BOINC Account Manager' menu?
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
NJMHoffmann
BAM!ID: 377
Joined: 2006-05-14
Posts: 32
Credits: 268,145
World-rank: 414,042

2006-07-07 09:55:26
last modified: 2006-07-07 10:32:39

Here with Firefox 1.5. After FF start:
Debug info:
ID1:377
ID2:
Hash:0e9f7a7006588c5f6616a573d5773971
Query:
stay_logged_in:
Logging:
Debug:1
End of debug info


After login ("stay logged in" checked):
Debug info:
ID1:377
ID2:377
Hash:0e9f7a7006588c5f6616a573d5773971
QueryELECT * FROM boincstats_ams.users
WHERE id = '377' AND hash = '0e9f7a7006588c5f6616a573d5773971' AND activated = '1'
stay_logged_in:!
Logging:
Debug:1356
End of debug info


Stop/start FF:
Debug info:
ID1:377
ID2:
Hash:0e9f7a7006588c5f6616a573d5773971
Query:
stay_logged_in:
Logging:
Debug:1
End of debug info


Hope that helps, Norbert
Honza
BAM!ID: 109
Joined: 2006-05-10
Posts: 154
Credits: 4,038,840,189
World-rank: 569

2006-07-07 10:02:42

I really don't get it.
Yeah, I also don't get it.
It happened only once and I can't replicate the behaviour any longer.
I've deleted all previous cookies from this site and will monitor more closely (and pay more attention to the circumstances).
NJMHoffmann
BAM!ID: 377
Joined: 2006-05-14
Posts: 32
Credits: 268,145
World-rank: 414,042

2006-07-07 10:03:32

Addition: Account manager menue at try 1 and 3 shows the login form.
(hmm: couldn't edit my previous post - connected?)

Norbert
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9237
Credits: 349,822,518
World-rank: 3,575

2006-07-07 10:07:05
last modified: 2006-07-07 10:08:13

I changed a check in the code, please try again (go directly to the testing page, not to the normal page first).
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
NJMHoffmann
BAM!ID: 377
Joined: 2006-05-14
Posts: 32
Credits: 268,145
World-rank: 414,042

2006-07-07 10:25:17
last modified: 2006-07-07 10:32:54

I changed a check in the code, please try again (go directly to the testing page, not to the normal page first).

Testing page working now even after unload FF first:

Debug info:
ID1:377
ID2:377
Hash:0e9f7a7006588c5f6616a573d5773971
QueryELECT * FROM boincstats_ams.users WHERE id = '377' AND hash = '0e9f7a7006588c5f6616a573d5773971' AND activated = '1'
stay_logged_in:!
Logging:
Debug:1356B
End of debug info

Norbert
(Thanks for editing my long line)
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9237
Credits: 349,822,518
World-rank: 3,575

2006-07-07 10:33:48

For those wondering about the edits to posts I made: I removed some info that could possibly (but most probably not) be used for account hijacking. Safety first!
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
KSMarksPsych
 
BAM!ID: 474
Joined: 2006-05-21
Posts: 139
Credits: 10,207,149
World-rank: 45,564

2006-07-07 13:01:51

I don't know what you did Willy, but it's working for me today.

I came and was logged in.

Good work.

(or perhaps it was a chance encounter of the 16th kind and tomorrow it'll be back to the old way).

Kathryn
thuffir
BAM!ID: 2427
Joined: 2006-06-21
Posts: 4
Credits: 53,081
World-rank: 888,173

2006-07-07 13:37:15
last modified: 2006-07-07 13:38:19

Even it is working for me now

Thanks Willy
Marky-UK
BAM!ID: 100
Joined: 2006-05-10
Posts: 77
Credits: 17,057,373
World-rank: 31,059

2006-07-07 20:28:18

Even it is working for me now

And me too. Nice one Willy.
Andrew Waddington
BAM!ID: 26
Joined: 2006-02-27
Posts: 2
Credits: 98,433
World-rank: 682,603

2006-07-10 22:57:06

Even it is working for me now

And me too. Nice one Willy.


Working here as well on the two machines i have used so far

Andrew
Pages: [1]

Index :: BAM! Bug Report :: Stay logged in not working for me.
Reason: