Pages: [1]
[C@B] rpperezr
 
BAM!ID: 45871
Joined: 2008-02-14
Posts: 5
Credits: 13,254,526
World-rank: 40,878

2008-03-26 09:44:36

I think that must not be allowed to put proyects resources to zero.

I did it because I rather assigned the resources independently to every computer.

I've had several events of LTD and STD going to infinity which is reported to the BOINC message board.

It seems that, some times after rebooting, the BOINC client takes first de general resource value (that was zero) before than the machine one.
Eppur si muove

KAMCOBILL
 
BAM!ID: 121
Joined: 2006-05-10
Posts: 95
Credits: 307,564,481
World-rank: 4,408

2008-03-29 17:17:53

If I'm understanding you correctly, you want to control resourses on each host independently, you should be able to select the host from here http://boincstats.com/bam/host_list.php to set independently. Or locally using advanced>preferences.
[C@B] rpperezr
 
BAM!ID: 45871
Joined: 2008-02-14
Posts: 5
Credits: 13,254,526
World-rank: 40,878

2008-03-29 19:59:39

If I'm understanding you correctly, you want to control resourses on each host independently, you should be able to select the host from here http://boincstats.com/bam/host_list.php to set independently. Or locally using advanced>preferences.


Oh, I apologize for my poor explanations.

Of course I can control each computer from de host_list. And I do.
The problem came when, after assigning resources in that page, I went to http://es.boincstats.com/bam/resources.php and I put zero to each project there.

Why I did a such thing? The main reason was that sometimes, after booting my computer, the resources assigned to each project at my BOINC Client were not taken from the host resources but the general resources of the project. As all the values were very similar in both pages I didn't know if I had to make a synchronization with BAM or not. I decided to put a "significant" value which clearly told me "It's necessary to synchronize!". (I'm sorry, I think all this is much messy to explain).

Then I put zero to all the project resources and that caused all client debts going to infinity and both the cpu scheduler and the work fetcher working bad (indeed not working at all).

Ergo, I think (and suggest) that zero value must not be permitted at general resources page.

Since I put each general project's resource to 100 I haven't got the error again. Now I synchronize with BAM immediately after each booting.

Hope to have explained sufficiently.

Eppur si muove

KAMCOBILL
 
BAM!ID: 121
Joined: 2006-05-10
Posts: 95
Credits: 307,564,481
World-rank: 4,408

2008-03-29 20:59:30

OK. Go it. I think setting to Zero in resources would shut down that project on all hosts which would cause a problem. If you would do it in the host it would just do that host. I see what you're talking about now. Actually, 0 resources would be about the same as No New Tasks.

Pages: [1]

Index :: BAM! Bug Report :: BAM Resources to 0
Reason: