Pages: [1]
Tom_unoduetre
    Donator
Tester
BAM!ID: 1183
Joined: 2006-05-31
Posts: 57
Credits: 9,950,073
World-rank: 43,623

2012-05-17 09:12:52

Hey,

I´m not sure if my work preference "home" is synchronized correctly to my host (BAM ID 368231). I can see the following host message:

17.05.2012 11:03:10 General prefs: no separate prefs for home_neu; using your defaults

"home_neu" was a preference I created for testing but deleted it again, and I´m using only "home" on my host.

Another issue which might be linked to that problem above is that my host suspends work if CPU load exceeds 25%, but in the aboce home preference I have set this value to 0 so no limitation should occur.

By the way, is the URL for the BAM account manager to be used still http://bam.boincstats.com/? Or has this changed with the new layout? Maybe this causes the issue?

I´m using Boinc client 7.0.25 with Boinctasks 1.32 as manager

Many thanks
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9181
Credits: 349,822,434
World-rank: 3,279

2012-05-17 09:24:32

The BAM! url is unchanged.

Can you sync the host again, then I can check the logs.
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
Tom_unoduetre
    Donator
Tester
BAM!ID: 1183
Joined: 2006-05-31
Posts: 57
Credits: 9,950,073
World-rank: 43,623

2012-05-17 09:32:11

done
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9181
Credits: 349,822,434
World-rank: 3,279

2012-05-17 09:37:43

OK, this is the preferences part of the BAM! reply:
Code:
<global_preferences>
<host_specific/>
<source_project>http://bam.boincstats.com/</source_project>
<mod_time>1337245179</mod_time>
<run_if_user_active>1</run_if_user_active>
<run_gpu_if_user_active/>
<suspend_if_no_recent_input>0</suspend_if_no_recent_input>
<cpu_scheduling_period_minutes>60</cpu_scheduling_period_minutes>
<idle_time_to_run>3</idle_time_to_run>
<work_buf_min_days>4</work_buf_min_days>
<work_buf_additional_days>2</work_buf_additional_days>
<max_cpus>2</max_cpus>
<max_ncpus_pct>100</max_ncpus_pct>
<suspend_cpu_usage>0</suspend_cpu_usage>
<cpu_usage_limit>0</cpu_usage_limit>
<disk_interval>300</disk_interval>
<disk_max_used_gb>20</disk_max_used_gb>
<disk_max_used_pct>50</disk_max_used_pct>
<disk_min_free_gb>1.5</disk_min_free_gb>
<vm_max_used_pct>75</vm_max_used_pct>
<ram_max_used_busy_pct>0</ram_max_used_busy_pct>
<ram_max_used_idle_pct>0</ram_max_used_idle_pct>
<max_bytes_sec_down>0</max_bytes_sec_down>
<max_bytes_sec_up>0</max_bytes_sec_up>
<hangup_if_dialed/>
<start_hour>0</start_hour>
<end_hour>0</end_hour>
<net_start_hour>0</net_start_hour>
<net_end_hour>0</net_end_hour>
</global_preferences>

The bold line is the CPU limit, as you can see it is set to '0' (you can verify this in your acct_mgr_reply.xml file).

Do you have local preferences set? They override project/BAM! preferences.
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
Tom_unoduetre
    Donator
Tester
BAM!ID: 1183
Joined: 2006-05-31
Posts: 57
Credits: 9,950,073
World-rank: 43,623

2012-05-17 09:48:53

Ok, that seems to work, I still wonder why I get the message "no separate prefs for home_neu; using your defaults" when there´s no "home_neu" preference?
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9181
Credits: 349,822,434
World-rank: 3,279

2012-05-17 10:07:26

Tom_unoduetre wrote:

Ok, that seems to work, I still wonder why I get the message "no separate prefs for home_neu; using your defaults" when there´s no "home_neu" preference?

That should be fixed now, please confirm.
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
Tom_unoduetre
    Donator
Tester
BAM!ID: 1183
Joined: 2006-05-31
Posts: 57
Credits: 9,950,073
World-rank: 43,623

2012-05-17 10:41:48

still shows home_neu I´m afraid.
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9181
Credits: 349,822,434
World-rank: 3,279

2012-05-17 10:55:31

As you can see in your acct_mgr_reply.xml file the venue is not included, so it appears the host is caching this.

I tried something to make the host "forget" it. Let me know the result.
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
Tom_unoduetre
    Donator
Tester
BAM!ID: 1183
Joined: 2006-05-31
Posts: 57
Credits: 9,950,073
World-rank: 43,623

2012-05-17 11:02:45

Still no venue in the xml file. I also created a 2nd preference Work and linked the host to it, but still it shows home_neu

Would a disconnect and reconnect from BAM maybe work?
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9181
Credits: 349,822,434
World-rank: 3,279

2012-05-17 11:16:48

I don't think so. I've set the venue to empty in the reply, but that doesn't seem to help. The host is ignoring that and remembers the old venue. Detaching won't fix that (I think).

A rather crude way that might fix it would be to stop the client, edit client_state.xml, remove the <host_venue> tag and restart the client. Le me know if that does the trick.
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
Tom_unoduetre
    Donator
Tester
BAM!ID: 1183
Joined: 2006-05-31
Posts: 57
Credits: 9,950,073
World-rank: 43,623

2012-05-17 11:56:52
last modified: 2012-05-17 12:01:01

ok, I deleted the <venue> tag, now I have Host location: None, although "home" is set here in BAM. So somehow this is not transferred to the client.

Edit: By the way, it´s really not an urgent issue so it´s fine if you want to enjoy your national holiday :-)
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9181
Credits: 349,822,434
World-rank: 3,279

2012-05-17 12:06:14

[OT]: The new BOINCstats was released today because of the national holiday and the three free days I have following today. Gives me plenty of time to attend to the problems that inevitably will be found.[/OT]

None as venue seems to be ok. Do you still get the venue warning?

BAM! no longer works with venues, they essentially serve no purpose anymore. You can indeed select a preference for your host, and the settings within that preference are send to the host as "host specific" settings, which override anything set anywhere else except for local preferences.
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
Tom_unoduetre
    Donator
Tester
BAM!ID: 1183
Joined: 2006-05-31
Posts: 57
Credits: 9,950,073
World-rank: 43,623

2012-05-17 12:21:59

ok, thanks for the explanation. Then I guess everything works fine. I´m just confused why the given name of the preference does not show in the messages, currently it says "General prefs: using your defaults" which is fine with me if I only knew those are actually the preferences I have set here in BAM.
[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9181
Credits: 349,822,434
World-rank: 3,279

2012-05-17 12:26:50

Hmmm, I'm not sure how to visually verify that. I suppose you should see the correct prefs when going to Tools->Computing preferences.
Please do not PM, IM or email me for support (they will go unread/ignored). Use the forum for support.
Pages: [1]

Index :: BAM! Bug Report :: work preference will not sync correctly to host
Reason: