Pages: [1]
Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 9,942,670,571
World-rank: 275

2015-04-02 07:13:09

I just created a new Work Preferences which is exactly the same as my Global scheme (which itself is a modified version of the default Global), but with a more restricted hour range: "Do work only between the hours of 1:00-15:00"

The problem is, when I edit my new scheme, the editboxes show 1:00 and 15:00. However, when I am not in the editing mode, it shows as no restriction.

And, when I assign that scheme to a host, and force a sync with BAM! on that host, the host gets unrestricted hours (0:00-0:00) and NOT what I wanted it to have (01:00-15:00).

Clearly, this is NOT good.

Earlier today, before I told my hosts to use BAM! (they were on GridRepublic), I created my modified Global scheme on the web (which has 0:00-0:00), then CLEAR'd my Settings dialog on all my hosts, then started using BAM! on them, and all the settings I heavily edited came to the hosts fine. But the restricted time range in this new scheme simply doesn't make it to the host, and it doesn't look right on Work Preferences.

As a workaround, I edited those hours directly in the dialog on the host, but that probably means that if I were to change any of the settings on BAM! for that scheme, the host won't get them since it is now using a local version of settings.

This is a huge bummer. I was really looking forward to using BAM! exclusively to edit everything my hosts should care about.

victor_sueca
 
BAM!ID: 154852
Joined: 2013-11-03
Posts: 39
Credits: 959,049
World-rank: 193,714

2015-04-03 07:25:02

And even worse, i think that if your computer sync again with BOINCstats it may get the wrong setting again. You should check it.

Tuna Ertemalp
    Donator
Tester
BAM!ID: 37744
Joined: 2007-10-31
Posts: 531
Credits: 9,942,670,571
World-rank: 275

2015-04-04 01:23:46

Luckily, BOINC manager seems to ignore the settings coming from the account manager once the user has made a change locally, until s/he hits the CLEAR button... Phew...

PaxBillyPax
BAM!ID: 210889
Joined: 2016-10-07
Posts: 1
Credits: 1,818,380
World-rank: 132,116

2016-10-14 12:52:18
last modified: 2016-10-14 12:53:01

I am having the same issue. Is there a solution to this yet?
clip
 
BAM!ID: 100194
Joined: 2011-05-17
Posts: 3
Credits: 557,254
World-rank: 262,589

2018-03-29 09:10:06

BAM! :: Work preference > Processor usage > Do work only between the hours of ...
when 'not in the editing mode, it shows as no restriction' still.

On clients that don't show the limiting by hours option, this setting is nice to have.
Pages: [1]

Index :: BAM! Bug Report :: Restricted hours in Work Preference doesn't look correct while editing, and doesn't get sent to the host
Reason: