Pages: [1]
Buckeye74
BAM!ID: 3063
Joined: 2006-07-11
Posts: 9
Credits: 4,267,610,910
World-rank: 654

2007-12-21 13:56:51

With Boinc 5.10.30, I have tried different numbers under Network Usage to try to maintain enough work for 3 days. No matter what, I download only about 3 hours of work at a time.

My computer shows BOINC runs .9% of the time when it is probably 99.999%. I have a feeling this is the problem.


CPU type GenuineIntel
Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz [x86 Family 6 Model 15 Stepping 6]
Number of CPUs 2
Operating System Microsoft Windows XP
Professional Edition, Service Pack 2, (05.01.2600.00)
Memory 2046.48 MB
Cache 488.28 KB
Swap space 3939.39 MB
Total disk space 139.72 GB
Free Disk Space 97.98 GB
Measured floating point speed 2342.94 million ops/sec
Measured integer speed 5261.06 million ops/sec
Average upload rate 2.81 KB/sec
Average download rate 109.61 KB/sec
Average turnaround time 4.14 days
Maximum daily WU quota per CPU 800/day
Tasks 2829
Number of times client has contacted server 25
Last time contacted server 21 Dec 2007 13:28:33 UTC
% of time BOINC client is running 100 %
While BOINC running, % of time work is allowed 0.9032 %
Average CPU efficiency 0.9389
Result duration correction factor 1.01125

Any ideas to maintain 3 days of work on this machine?
Cori
 
BAM!ID: 2
Joined: 2006-01-09
Posts: 1351
Credits: 69,052,230
World-rank: 12,870

2007-12-21 14:43:51
last modified: 2007-12-21 14:46:25

I suppose you have your computer running 24/7?
Maybe some preferences got messed up? I would check first the BOINC manager prefs under 'extras' -> 'preferences'. Perhaps it is set to do no work when your computer is in use by accident? Maybe increasing the work cache ('connect about every xx days') plus additional work buffer helps, too.

Although I have also experienced that it can depend on the project's behaviour how much work you really get: Sometimes you want little work but when crunching for projects with BIG WUs you still get work for at least a day because there aren't shorter WUs.
Sometimes you want LOTs of work but the project only sends 4 or 10 WUs at a time and those will be finished way too quickly.

I guess you have to experiment a bit. I also use a little trick sometimes to get work: when crunching for two projects for example I suspend project A manually for a short time, then project B fetches work and I can resume project A again.

Greetings from Cori
Buckeye74
BAM!ID: 3063
Joined: 2006-07-11
Posts: 9
Credits: 4,267,610,910
World-rank: 654

2007-12-21 14:55:37

Yep, it runs 24/7, to try to fix this I only have one project on this machine, it's set to run anytime. I have played around with the settings to no avail.
PovAddict
BAM!ID: 115
Joined: 2006-05-10
Posts: 1013
Credits: 5,543,874
World-rank: 76,115

2007-12-21 15:46:43

Yep, it runs 24/7, to try to fix this I only have one project on this machine, it's set to run anytime. I have played around with the settings to no avail.

Stop BOINC. Edit client_state.xml to have <active_frac>1</active_frac>. Restart BOINC. Now: "While BOINC running, % of time work is allowed 100 %"
Not running BOINC anymore for several reasons...
Buckeye74
BAM!ID: 3063
Joined: 2006-07-11
Posts: 9
Credits: 4,267,610,910
World-rank: 654

2007-12-21 16:06:49

I found the <active_frac>1</active_frac> but it will not let me edit it. Is there a way to make BOINC change it itself? Yesterday I uninstalled BOINC then reinstalled but that didn't change the active fraction.
PovAddict
BAM!ID: 115
Joined: 2006-05-10
Posts: 1013
Credits: 5,543,874
World-rank: 76,115

2007-12-21 16:09:59

I found the <active_frac>1</active_frac> but it will not let me edit it. Is there a way to make BOINC change it itself? Yesterday I uninstalled BOINC then reinstalled but that didn't change the active fraction.

Uninstalling BOINC doesn't remove the client_state.xml, or any work in progress.

Did you stop BOINC before opening the file?
Not running BOINC anymore for several reasons...
Buckeye74
BAM!ID: 3063
Joined: 2006-07-11
Posts: 9
Credits: 4,267,610,910
World-rank: 654

2007-12-21 16:18:07

Yes, I did stop BOINC.
mo.v
BAM!ID: 25128
Joined: 2007-05-01
Posts: 280
Credits: 0
World-rank: 0

2007-12-21 20:37:25


Hi Buckeye

You could have a look at the click-by-click instructions in the HOW TO FIX IT section of this this post, starting from the second or third starred item because unless you have any really long tasks in progress you won't want the hassle of making a backup of the BOINC folder first as a precaution. Note that it was written to explain how to edit a different xml file, but the method should be the same.

http://www.climateprediction.net/board/viewtopic.php?t=7215
mo.v
BAM!ID: 25128
Joined: 2007-05-01
Posts: 280
Credits: 0
World-rank: 0

2007-12-21 20:53:50


In your boinc manager > Advanced > Preferences I think you also need to make sure that the work buffer time is set for example to the maximum time of 10 days.

But as far as I can see, if I only have one project set to Allow New Work, I can have less than 10 days' work left and no new tasks are sent to me. This is with 5.10.28. It's a big nuisance. Crunchers shouldn't really have to edit their xml files to get enough tasks. I can't understand why just editing the buffer time doesn't work. Maybe it works with some projects but not others?

Buckeye74
BAM!ID: 3063
Joined: 2006-07-11
Posts: 9
Credits: 4,267,610,910
World-rank: 654

2007-12-21 21:10:17

Thanks mo.v and PovAddict!!

Now it's requesting 1.1 million seconds of work...that oughta do it!

mo.v
BAM!ID: 25128
Joined: 2007-05-01
Posts: 280
Credits: 0
World-rank: 0

2007-12-21 21:38:27

Can you please tell us what you needed to edit - only the work buffer, or only the xml file, or both?
PovAddict
BAM!ID: 115
Joined: 2006-05-10
Posts: 1013
Credits: 5,543,874
World-rank: 76,115

2007-12-21 21:46:32

Crunchers shouldn't really have to edit their xml files to get enough tasks.

If a user has his computer turned off for a month, when he turns it back on, the on_frac will be very low. Unless he edits it, he will get little work until the number starts slowly going back up.
Not running BOINC anymore for several reasons...
Buckeye74
BAM!ID: 3063
Joined: 2006-07-11
Posts: 9
Credits: 4,267,610,910
World-rank: 654

2007-12-21 22:00:02
last modified: 2007-12-21 22:01:58

With Notepad, I edited <active_frac>0.932000</active_frac> to
<active_frac>1.000000</active_frac>, and had the work buffer set to 2 days plus maintain add'l 5 days work.

My computer has not been off for a year or so except for sometimes when Windows Update shuts it down.
PovAddict
BAM!ID: 115
Joined: 2006-05-10
Posts: 1013
Credits: 5,543,874
World-rank: 76,115

2007-12-22 00:49:25

My computer has not been off for a year or so except for sometimes when Windows Update shuts it down.

Your problem was active_frac, not on_frac. I was just giving an example on why those values could get off and need manual tweaking. (I don't know why your active_frac went low).
Not running BOINC anymore for several reasons...
WyerByter
 
BAM!ID: 3895
Joined: 2006-08-10
Posts: 377
Credits: 220,278,517
World-rank: 5,722

2007-12-22 17:22:35

The other interesting thing i noticed was the numbers. He said that the active_frac was 0.932 and reported as 0.932%. Then he changed it to 1, (I am assuming it reports 100%). Could this be an error in BOINC, or the particular project?
This signature was stolen from somewhere.


Buckeye74
BAM!ID: 3063
Joined: 2006-07-11
Posts: 9
Credits: 4,267,610,910
World-rank: 654

2007-12-22 18:21:08

I had multiple projects and they all showed the .9% before I fixed it.
Keck_Komputers
 
BAM!ID: 571
Joined: 2006-05-22
Posts: 178
Credits: 26,938,574
World-rank: 25,000

2007-12-23 07:54:49

The other interesting thing i noticed was the numbers. He said that the active_frac was 0.932 and reported as 0.932%. Then he changed it to 1, (I am assuming it reports 100%). Could this be an error in BOINC, or the particular project?

I assumed it was a typo and he meant 0.0932 for the active_frac.
BOINC WIKI

BOINCing since 2002/12/8
PovAddict
BAM!ID: 115
Joined: 2006-05-10
Posts: 1013
Credits: 5,543,874
World-rank: 76,115

2007-12-23 19:09:45

I assumed it was a typo and he meant 0.0932 for the active_frac.

0.0932 is 9.32%
Not running BOINC anymore for several reasons...
Keck_Komputers
 
BAM!ID: 571
Joined: 2006-05-22
Posts: 178
Credits: 26,938,574
World-rank: 25,000

2007-12-24 02:33:52

I assumed it was a typo and he meant 0.0932 for the active_frac.

0.0932 is 9.32%

Hehe See that extra zero is easy to mistype.
BOINC WIKI

BOINCing since 2002/12/8
Pages: [1]

Index :: BOINC :: How to get a larger cache of workunits?
Reason: