Pages: [1]
Lazarus-uk
 
BOINCstats SOFA member
BAM!ID: 49667
Joined: 2008-04-08
Posts: 879
Credits: 664,934,093
World-rank: 2,346

2008-12-14 11:54:25


Some time ago I must have installed a version of BOINC as a service. I think this was the default setting on some of the 6.2.xx versions. Anywho, I have found that when trying to suspend work with my current BOINC manager (6.4.5), time to completion still continues to increase. So, if I suspend work, or set to run based on preferences (BOINC runs after 2mins idle), to install software or run antivirus etc. all my "to completion" times have increased. This is messing up the DCF on all my running projects and makes it impossible for me to get new work until it has come down again.

I can only assume that because I installed a previous version as service, that 6.4.5 was installed on top of it, also as a service. I would not have done this by choice. Is there any way to uninstall BOINC 6.4.5 as a service and then reinstall it, to program files, similar to 5.10.45, without losing any of my current work.

I know the preferred way to uninstall is through 'add/remove programs' (Win XP Pro-32) and that some of files are transferred back to the original folders in C:/Program Files/BOINC, but will I lose my current WUs.


Any advice will be greatly appreciated.



Guest

2008-12-14 12:30:11
last modified: 2008-12-14 12:50:25

First Suspend all your Projects (Suspend & Set to NNW)

Then make a complete separate (if they are in separate Directories, if not just the lone Directory then) copy of the Files Directory & .exe Directory if possible

Then Un-Install the BOINC Client thru the Add/Remove Program Utility

Then if Necessary Manually Delete the .exe's in the .exe Directory

Re-Install what ever Version Client you want and see what you got

If things are mucked up after the Client Installation you have your Backup Copies to just copy back where you got them from

Don't Un-Suspend the projects until your absolutely sure everything is okay with the Re-Install

Good Luck ...
Lazarus-uk
 
BOINCstats SOFA member
BAM!ID: 49667
Joined: 2008-04-08
Posts: 879
Credits: 664,934,093
World-rank: 2,346

2008-12-14 12:37:11


Good Luck ...




Somehow I just knew that this wasn't going to be straightforward.

Thanks PB, I'll go and have a root around for my directories, so to speak.

Guest

2008-12-14 12:49:22
last modified: 2008-12-14 12:53:16

Well everything I outlined is to insure you don't lose your WU's, if your brave & it doesn't matter just un-install & re-install the way you want & see what you got then. I do that a lot cause I'm lazy at times and every so often lose some work but most times everything turns out okay.

How I explained to do it isn't a Guaranteed way of doing it to insure you don't lose your Wu's, but it's the way I've done it many times and it's saved my Bacon on more than one occasion ...
Lazarus-uk
 
BOINCstats SOFA member
BAM!ID: 49667
Joined: 2008-04-08
Posts: 879
Credits: 664,934,093
World-rank: 2,346

2008-12-14 12:54:45


Well everything I outlined is to insure you don't lose your WU's, if your brave & it doesn't matter just un-install & re-install the way you want & see what you got then. I do that a lot cause I'm lazy at times and every so often lose some work but most times everything turns out okay ...




Well, I've only got one GPUgrid that has about 3mins left a WCG that has just finished and a couple of others that are just going to finish within the next 20 mins, so I'll let them finish, suspend all the others, and try for a complete uninstall/reinstall.


Thanks for the help PB


Mark


[BOINCstats] Willy
 
Forum moderator - Administrator - Developer - Tester - Translator
BAM!ID: 1
Joined: 2006-01-09
Posts: 9263
Credits: 349,822,518
World-rank: 3,734

2008-12-14 12:56:16
last modified: 2008-12-14 12:57:52

Why not go to Control Panel -> Administrative Tools -> Services, then doubleclick the BOINC service and set the startup type to Disabled.

Then add a link to boincmgr.exe in your Startup folder in your startmenu. If you want it to run for all users, add it to the Startup folde of All User.

I think that's a lot quicker, easier, and it still won't run as a service anymore.

Edit: to stop the service after this, do WinKey+R (run menu) and type "NET STOP BOINC". Then start BOINC via the link in the start-up menu.
Lazarus-uk
 
BOINCstats SOFA member
BAM!ID: 49667
Joined: 2008-04-08
Posts: 879
Credits: 664,934,093
World-rank: 2,346

2008-12-14 13:06:11


Why not go to Control Panel -> Administrative Tools -> Services, then doubleclick the BOINC service and set the startup type to Disabled.

Then add a link to boincmgr.exe in your Startup folder in your startmenu. If you want it to run for all users, add it to the Startup folde of All User.

I think that's a lot quicker, easier, and it still won't run as a service anymore.

Edit: to stop the service after this, do WinKey+R (run menu) and type "NET STOP BOINC". Then start BOINC via the link in the start-up menu.




That sounds like a plan. Thanks Willy.

I was only going to reinstall 6.4.5 anyway and I can't upload my GPUgrid task at the moment. They must have server probs and I don't want to lose those 3000+ credits.

Thanks to you both for your help.


Mark


Jord
BAM!ID: 18
Joined: 2006-01-31
Posts: 83
Credits: 20,410,823
World-rank: 28,351

2008-12-14 14:54:02
last modified: 2008-12-14 14:55:23

Why not go to Control Panel -> Administrative Tools -> Services, then doubleclick the BOINC service and set the startup type to Disabled.

Then add a link to boincmgr.exe in your Startup folder in your startmenu. If you want it to run for all users, add it to the Startup folde of All User.

I think that's a lot quicker, easier, and it still won't run as a service anymore.

You'll find that it won't run at all if you set the service to disabled. Just starting the BOINC Manager then won't start up BOINC, as the registry still says that the installation is a service install.

By the way, if you installed 6.4.5 over 6.2.19 and left the installation options in the installer to the default options, then BOINC is no longer installed as a service. Since 6.4.4 the default installation is not a service; to make sure this is followed, it uses a new registry entry that the previous versions don't use, while ignoring the old registry setting that the previous clients used.

Easily checked by doing BOINC Manager->File->Exit, then checking in task manager if boinc.exe is still running. If it is, then you changed the installation method while installing 6.4.5 ...
Lazarus-uk
 
BOINCstats SOFA member
BAM!ID: 49667
Joined: 2008-04-08
Posts: 879
Credits: 664,934,093
World-rank: 2,346

2008-12-14 15:24:31
last modified: 2008-12-14 15:31:27

Why not go to Control Panel -> Administrative Tools -> Services, then doubleclick the BOINC service and set the startup type to Disabled.

Then add a link to boincmgr.exe in your Startup folder in your startmenu. If you want it to run for all users, add it to the Startup folde of All User.

I think that's a lot quicker, easier, and it still won't run as a service anymore.

You'll find that it won't run at all if you set the service to disabled. Just starting the BOINC Manager then won't start up BOINC, as the registry still says that the installation is a service install.

By the way, if you installed 6.4.5 over 6.2.19 and left the installation options in the installer to the default options, then BOINC is no longer installed as a service. Since 6.4.4 the default installation is not a service; to make sure this is followed, it uses a new registry entry that the previous versions don't use, while ignoring the old registry setting that the previous clients used.

Easily checked by doing BOINC Manager->File->Exit, then checking in task manager if boinc.exe is still running. If it is, then you changed the installation method while installing 6.4.5 ...



Yes, of course you're right I dont have BOINC installed as a service. I assumed it was a service, because of the way the 'To completion' time still increases after BOINC is suspended or I am 'active'. I installed 6.4.5 over 6.4.2 and just followed the default settings all the way through the install. I didn't really pay any attention to where or how BOINC was being installed.

So, the only way I have to stop the 'to completion' time increasing while I may want to do other things with the PC is to manually 'Exit' BOINC and tick the 'Stop running science applications...' box when doing so. Or perhaps there could be some other explanation for my problem. Might this perhaps be a bug with 6.4.5.?

At the moment it kinda defeats the philosophy of BOINC to use peoples idle computer time, when the users are active or have manually suspended the BOINC manager and tasks still keep clocking up time.

Thanks for your input Ageless. It is much appreciated.


Mark


[Edit] I do realise that this a Beta version and have searched the dev forums for similar problems to mine but have not seen anything similar. Just thought someone may have come across it here.[/Edit]

[another-edit] The reason I've not gone back to an older version of BOINC, is that 6.4.5 is the recommended version for GPUgrid[/another-edit]


Jord
BAM!ID: 18
Joined: 2006-01-31
Posts: 83
Credits: 20,410,823
World-rank: 28,351

2008-12-14 20:16:20

So, the only way I have to stop the 'to completion' time increasing while I may want to do other things with the PC is to manually 'Exit' BOINC and tick the 'Stop running science applications...' box when doing so. Or perhaps there could be some other explanation for my problem.

Hmmm, there's something I should test out... do I also get the option to exit running science applications upon exiting BOINC Manager when BOINC is not installed as a service? ... for of course this is a double entry as when BOINC isn't a service, going File->Exit in BOINC Manager should exit any running science application.

Might this perhaps be a bug with 6.4.5.?

It could be, there are enough of them already. Hold on though, is it doing this on all projects or only those using the GPU?

Aren't some people on GPUGrid saying it's better to go back to 6.3.23 or 6.4.2?

If you do go back to any of those versions, do make sure to go through the Advanced button in the installer (see this FAQ (3rd screen in the installer) and unchecking the Protected Application Execution mode. This is the service install. You can downgrade over an existing BOINC version these days, no need to uninstall BOINC through Add/Remove Programs. Just start the installer of the previous version.
Lazarus-uk
 
BOINCstats SOFA member
BAM!ID: 49667
Joined: 2008-04-08
Posts: 879
Credits: 664,934,093
World-rank: 2,346

2008-12-14 20:38:42


Hold on though, is it doing this on all projects or only those using the GPU?



Yes it's doing it on all the projects I have running: currently, Milkyway, WCG and GPU


Aren't some people on GPUGrid saying it's better to go back to 6.3.23 or 6.4.2?



There seems to be mixed opinions there - some people have changed back to 6.4.2 but i'm very happy with 6.4.5, apart from this minor problem, which isn't such a problem now I know that it happens. I just have to make sure to exit BOINC completely when I want to run antivirus, install software, etc, which is a good thing to do anyway. Apart from that, whenever the pc is running BOINC is running.


If you do go back to any of those versions, do make sure to go through the Advanced button in the installer (see this FAQ (3rd screen in the installer) and unchecking the Protected Application Execution mode. This is the service install. You can downgrade over an existing BOINC version these days, no need to uninstall BOINC through Add/Remove Programs. Just start the installer of the previous version.



Thanks for the advice Jord. It is much appreciated. I'll stick with 6.4.5 for now. Im starting to get used to its funny ways

Mark


Jord
BAM!ID: 18
Joined: 2006-01-31
Posts: 83
Credits: 20,410,823
World-rank: 28,351

2008-12-15 13:50:59

I assumed it was a service, because of the way the 'To completion' time still increases after BOINC is suspended or I am 'active'. I installed 6.4.5 over 6.4.2 and just followed the default settings all the way through the install. I didn't really pay any attention to where or how BOINC was being installed.

This "time to completion" increasing when you suspend BOINC, or snooze it, is normal when you don't use "leave applications in memory". When you suspend an app it loses the CPU time back to its last checkpoint, so the time to completion goes up a little.
Lazarus-uk
 
BOINCstats SOFA member
BAM!ID: 49667
Joined: 2008-04-08
Posts: 879
Credits: 664,934,093
World-rank: 2,346

2008-12-15 14:52:53

I assumed it was a service, because of the way the 'To completion' time still increases after BOINC is suspended or I am 'active'. I installed 6.4.5 over 6.4.2 and just followed the default settings all the way through the install. I didn't really pay any attention to where or how BOINC was being installed.

This "time to completion" increasing when you suspend BOINC, or snooze it, is normal when you don't use "leave applications in memory". When you suspend an app it loses the CPU time back to its last checkpoint, so the time to completion goes up a little.




I do leave Apps. suspended in memory. The 'to completion' rises but 'cpu time' and 'progress' remain the same. But when the WUs finishes, the extra time, it was supposedly idle, is added on to the WU finishing and all other WUs from the same project. So if I suspend work for 20 mins, then 20 mins is added to that WU and all others from the same project. It happens with WUs from all projects.



Mark

Jord
BAM!ID: 18
Joined: 2006-01-31
Posts: 83
Credits: 20,410,823
World-rank: 28,351

2008-12-15 15:26:42

Then set up a cc_config.xml file.

To do so, open Notepad, in it copy the following:

<cc_config>
<log_flags>
<task>1</task>
<file_xfer>1</file_xfer>
<sched_ops>1</sched_ops>
<state_debug>0</state_debug>
<task_debug>1</task_debug>
<file_xfer_debug>0</file_xfer_debug>
<sched_op_debug>0</sched_op_debug>
<http_debug>0</http_debug>
<work_fetch_debug>0</work_fetch_debug>
<unparsed_xml>1</unparsed_xml>
<proxy_debug>0</proxy_debug>
<time_debug>0</time_debug>
<http_xfer_debug>0</http_xfer_debug>
<benchmark_debug>1</benchmark_debug>
<poll_debug>0</poll_debug>
<guirpc_debug>0</guirpc_debug>
<scrsave_debug>0</scrsave_debug>
<rr_simulation>0</rr_simulation>
<cpu_sched>1</cpu_sched>
<cpu_sched_debug>1</cpu_sched_debug>
<app_msg_send>0</app_msg_send>
<app_msg_receive>0</app_msg_receive>
<mem_usage_debug>0</mem_usage_debug>
<network_status_debug>0</network_status_debug>
<checkpoint_debug>1</checkpoint_debug>
</log_flags>
<cc_config>

Then save the file, naming it cc_config.xml to your BOINC Data directory (Default at C:\Documents and Settings\All Users\Application Data\BOINC\ ). Make sure you use the "all files" option to save the file with, but do check it in the directory on not getting the .TXT extension. If it did, rename it so it only has the .XML extension.

Then open BOINC Manager->Advanced view->Advanced->Read config file.
In the Messages it should show that it has read the cc_config.xml file. Also in the messages a lot more messages will start to show now.
Suspend BOINC.

Let it sit like that for 2 minutes, then Resume BOINC.
Now copy all the messages from the moment you read the cc_config.xml file to the end and email them to me at the address I PM'ed you.

If anything isn't clear, please ask.
When you don't want to continue debugging BOINC afterwards, set the [task_debug] and [cpu_sched_debug] flags in cc_config from one to zero and save the file. Then let BOINC reread the config file.
PovAddict
BAM!ID: 115
Joined: 2006-05-10
Posts: 1013
Credits: 3,809,717
World-rank: 93,035

2008-12-16 16:19:58

Yes, of course you're right I dont have BOINC installed as a service. I assumed it was a service, because of the way the 'To completion' time still increases after BOINC is suspended or I am 'active'. I installed 6.4.5 over 6.4.2 and just followed the default settings all the way through the install. I didn't really pay any attention to where or how BOINC was being installed.

So, the only way I have to stop the 'to completion' time increasing while I may want to do other things with the PC is to manually 'Exit' BOINC and tick the 'Stop running science applications...' box when doing so. Or perhaps there could be some other explanation for my problem. Might this perhaps be a bug with 6.4.5.?[/Edit]


It seems to be a bug, yes. Setting it to "suspended" from BOINC Manager "Activity" menu always works. Detecting user activity works fine installed as a service since they added boinctray.exe. If the time to completion changes at all while it should be suspended, it must be some other problem. Do the workunits still say "Running" when they do that?

[another-edit] The reason I've not gone back to an older version of BOINC, is that 6.4.5 is the recommended version for GPUgrid[/another-edit]

Yes, you need 6.4.x to work with GPU apps.
Not running BOINC anymore for several reasons...
Guest

2008-12-16 16:24:30

The reason I've not gone back to an older version of BOINC, is that 6.4.5 is the recommended version for GPUgrid[/another-edit]


they went back for 6.4.2 as reccomended since 6.4.5 is a big foulup..

Lazarus-uk
 
BOINCstats SOFA member
BAM!ID: 49667
Joined: 2008-04-08
Posts: 879
Credits: 664,934,093
World-rank: 2,346

2008-12-16 21:09:11

Yes, of course you're right I dont have BOINC installed as a service. I assumed it was a service, because of the way the 'To completion' time still increases after BOINC is suspended or I am 'active'. I installed 6.4.5 over 6.4.2 and just followed the default settings all the way through the install. I didn't really pay any attention to where or how BOINC was being installed.

So, the only way I have to stop the 'to completion' time increasing while I may want to do other things with the PC is to manually 'Exit' BOINC and tick the 'Stop running science applications...' box when doing so. Or perhaps there could be some other explanation for my problem. Might this perhaps be a bug with 6.4.5.?[/Edit]


It seems to be a bug, yes. Setting it to "suspended" from BOINC Manager "Activity" menu always works. Detecting user activity works fine installed as a service since they added boinctray.exe. If the time to completion changes at all while it should be suspended, it must be some other problem. Do the workunits still say "Running" when they do that?

[another-edit] The reason I've not gone back to an older version of BOINC, is that 6.4.5 is the recommended version for GPUgrid[/another-edit]

Yes, you need 6.4.x to work with GPU apps.



Ok I just spent 20 mins composing a reply to this thread and it got lost in space!!. Second, and much shorter, attempt...

Just to put everything together into one post.

I'm running BOINC 6.4.5 on WIN XP Pro (SP3) 32-bit and a Q9450 quad.
BOINC is not installed as a servive. i just assumed that it was because of the way it behaved when I tried to suspend.

When I 'suspend' from the 'activity' menu in the BOINC manager, the symptoms are:

CPU time - stops
Progress bar/percentage - stops
Time to completions - increases @ 1 second/second (normal time)
WUs show as 'suspended'
Task manager show - 00 CPU is being used by WUs

When activity resumes, after clicking 'run always' the CPU time and Progress bar/percentage carry on from where it was suspended, but because the time to completion has increased then the effective run-time of the WUs increases by the amount of time the WUs were 'suspended'.


they went back for 6.4.2 as reccomended since 6.4.5 is a big foulup..


Apart from this problem I've been quite happy with 6.4.5. The cc_config.xml has gone of to the developers. hopefully I can help sort out this problem. with some luck, it may do some good for future versions.


Thanks for the suggestions guys. I'm still trying other options to see if I can stop it doing this.


Mark



Guest

2008-12-16 21:16:33

I'm still trying other options to see if I can stop it doing this.


I'm going to kill that cat..
Lazarus-uk
 
BOINCstats SOFA member
BAM!ID: 49667
Joined: 2008-04-08
Posts: 879
Credits: 664,934,093
World-rank: 2,346

2008-12-16 21:19:53

I'm still trying other options to see if I can stop it doing this.


I'm going to kill that cat..




How did you know I have a cat???


Jord
BAM!ID: 18
Joined: 2006-01-31
Posts: 83
Credits: 20,410,823
World-rank: 28,351

2008-12-16 22:16:04

I'm still trying other options to see if I can stop it doing this.


I'm going to kill that cat..



How did you know I have a cat???

My cat is luckily too afraid of the computer room...
Guest

2008-12-16 22:26:39

How did you know I have a cat???


didn't know - been with those submarine guys back then and learned that the only use is to help your rheumatism. of course it will only help if you kill the cat..
Pages: [1]

Index :: BOINC :: Uninstalling BOINC as a service
Reason: