Pages: [1]
dskrbt
 
BAM!ID: 82585
Joined: 2010-03-10
Posts: 25
Credits: 3,641,632
World-rank: 90,481

2010-07-03 07:44:03

Need some advice regarding cc_config.xml

want to stop boinc running cpu and gpu when playing halflife2 games, exe is hl2.exe. Put this in cc_config.xml, but nothing happens.
I am using boinctasks, not boincmanager, could this be a problem or is there some else that needs to go here
"<cc_config>
<log_flags>
</log_flags>
<options>
<exclusive_app>hl2.exe</exclusive_app>
<exclusive_gpu_app>hl2.exe</exclusive_gpu_app>
</options>
</cc_config>"

any help would be appreciated
Gundolf Jahn
 
BAM!ID: 16586
Joined: 2007-01-07
Posts: 469
Credits: 447,470
World-rank: 311,526

2010-07-03 09:13:23

If you want BOINC to suspend (CPU and GPU) when you are running that exe, you only need <exclusive_app>.

Did you restart the BOINC client after changing cc_config.xml (reboot)?

Are there any messages concerning the configuration in your Messages tab?

Gruß,
Gundolf
Computer sind nicht alles im Leben. (Kleiner Scherz)
STE\/E
Tester
BAM!ID: 57534
Joined: 2008-08-27
Posts: 2078
Credits: 1,910,570,562,285
World-rank: 2

2010-07-03 10:46:30
last modified: 2010-07-03 11:24:02

Gundolf Jahn wrote:
If you want BOINC to suspend (CPU and GPU) when you are running that exe, you only need <exclusive_app>.

Did you restart the BOINC client after changing cc_config.xml (reboot)?

Are there any messages concerning the configuration in your Messages tab?

Gruß,
Gundolf


You don't have to stop & restart the BOINC Client if using the BOINC Manager after making changes to the cc_config.xml file ... All you have to do is drop down the Advanced Menu on the top Left Hand side of the BOINC Manager and then Click on "Read Config File" and the changes are recognized by the BOINC Client. That's all I ever do and the changes always work ...
Crystal Pellet
 
Tester - BOINCstats SOFA member
BAM!ID: 64136
Joined: 2009-01-12
Posts: 4521
Credits: 358,627,735
World-rank: 3,316

2010-07-03 10:58:43

dskrbt wrote:
Need some advice regarding cc_config.xml

want to stop boinc running cpu and gpu when playing halflife2 games, exe is hl2.exe. Put this in cc_config.xml, but nothing happens.
I am using boinctasks, not boincmanager, could this be a problem or is there some else that needs to go here
"<cc_config>
<log_flags>
</log_flags>
<options>
<exclusive_app>hl2.exe</exclusive_app>
<exclusive_gpu_app>hl2.exe</exclusive_gpu_app>
</options>
</cc_config>"

any help would be appreciated

If you're using BoincTasks, simple hoover over the BoincTasks icon in the taskbar, right click and select Snooze and/or Snooze Gpu.

Gundolf Jahn
 
BAM!ID: 16586
Joined: 2007-01-07
Posts: 469
Credits: 447,470
World-rank: 311,526

2010-07-03 11:32:43

PoorBoy wrote:
You don't have to stop & restart the BOINC Client if using the BOINC Manager after making changes to the cc_config.xml file ... All you have to do is drop down the Advanced Menu on the top Left Hand side of the BOINC Manager and then Click on "Read Config File" and the changes are recognized by the BOINC Client. That's all I ever do and the changes always work ...

That's not true for all options in cc_config.xml. Some need a restart of BOINC.

I'd at least try if it makes a difference.

Gruß,
Gundolf
STE\/E
Tester
BAM!ID: 57534
Joined: 2008-08-27
Posts: 2078
Credits: 1,910,570,562,285
World-rank: 2

2010-07-03 11:59:16

Gundolf Jahn wrote:
PoorBoy wrote:
You don't have to stop & restart the BOINC Client if using the BOINC Manager after making changes to the cc_config.xml file ... All you have to do is drop down the Advanced Menu on the top Left Hand side of the BOINC Manager and then Click on "Read Config File" and the changes are recognized by the BOINC Client. That's all I ever do and the changes always work ...

That's not true for all options in cc_config.xml. Some need a restart of BOINC.

I'd at least try if it makes a difference.

Gruß,
Gundolf


Possibly, but I haven't run into any changes yet that I had to re-start the client ...
dskrbt
 
BAM!ID: 82585
Joined: 2010-03-10
Posts: 25
Credits: 3,641,632
World-rank: 90,481

2010-07-03 13:01:31
last modified: 2010-07-03 13:03:34

the messages are as follows

3/07/2010 10:43:44 PM Config: don't compute while hl2.exe is running
3/07/2010 10:43:44 PM Config: don't use GPUs while hl2.exe is running
3/07/2010 10:43:44 PM log flags: file_xfer, sched_ops, task

yes i have restarted and refreshed, right click read config file
but still hl2.exe runs and still science runs
i have a print screen file to prove it, can i upload it

and yes i know that boinctasks can snooze but i want auto stop start
so that i don't have to stop start EVERY TIME.

TIA
Crystal Pellet
 
Tester - BOINCstats SOFA member
BAM!ID: 64136
Joined: 2009-01-12
Posts: 4521
Credits: 358,627,735
World-rank: 3,316

2010-07-03 13:25:00
last modified: 2010-07-03 13:26:19

dskrbt wrote:
the messages are as follows

3/07/2010 10:43:44 PM Config: don't compute while hl2.exe is running
3/07/2010 10:43:44 PM Config: don't use GPUs while hl2.exe is running
3/07/2010 10:43:44 PM log flags: file_xfer, sched_ops, task

yes i have restarted and refreshed, right click read config file
but still hl2.exe runs and still science runs
i have a print screen file to prove it, can i upload it

and yes i know that boinctasks can snooze but i want auto stop start
so that i don't have to stop start EVERY TIME.

TIA

OK, I'll try again and tested it with notepad.exe.

It works. I get:

03-07-2010 15:23:31 Suspending computation - an exclusive app is running
03-07-2010 15:24:32 Resuming computation

I think the problem is that you have set your client to run always.
Set Activity: Based on preferences

ps: Read config file was enough without restarting BOINC.

dskrbt
 
BAM!ID: 82585
Joined: 2010-03-10
Posts: 25
Credits: 3,641,632
World-rank: 90,481

2010-07-03 13:36:01

SUCCESS it was "run always" very smart crystal pellet
thanks to all back to TF2
Pages: [1]

Index :: BOINC :: cc_config advice
Reason: