Pages: [1]
andreasschachl
BAM!ID: 18999
Joined: 2007-02-10
Posts: 4
Credits: 928,990
World-rank: 209,969

2012-12-31 13:40:23

Hi!

I'm having some very annoying problems with BOINC under Linux (more precise Ubuntu 12.04):

  1. After booting BOINC Manager does not recognize my Geforce 560 Ti - only if I stop BOINC service manually and start it again the GPU is available.
  2. Detection if computer is idle or not does not work - it always states "computer in use" even if computer is not in use - if I start work using "Activity" menu everything works as expected.



What I already tried:


  1. Using BOINC 7.0.42 (manually added using PPA) - still detection of idle computer does not work / same problem with GPU and even more no more progress in work-units displayed.
  2. Installing CUDA package from Ubuntu PPA -> did not change anything.




Can anybody please help / give me instructions on how to narrow the problems?

Thanks a lot!


Code:

cat global_prefs.xml
<global_preferences>
<source_project>http://bam.boincstats.com/</source_project>
<mod_time>1356721465</mod_time>
<ram_max_used_idle_pct>0</ram_max_used_idle_pct>
<work_buf_min_days>1</work_buf_min_days>
<cpu_usage_limit>90</cpu_usage_limit>
<disk_min_free_gb>1</disk_min_free_gb>
<end_hour>0</end_hour>
<suspend_cpu_usage>90</suspend_cpu_usage>
<disk_interval>60</disk_interval>
<leave_apps_in_memory/>
<max_bytes_sec_up>0</max_bytes_sec_up>
<max_bytes_sec_down>0</max_bytes_sec_down>
<run_gpu_if_user_active>0</run_gpu_if_user_active>
<ram_max_used_busy_pct>0</ram_max_used_busy_pct>
<idle_time_to_run>1</idle_time_to_run>
<start_hour>0</start_hour>
<max_cpus>10</max_cpus>
<disk_max_used_pct>50</disk_max_used_pct>
<net_end_hour>6</net_end_hour>
<net_start_hour>0</net_start_hour>
<work_buf_additional_days>3</work_buf_additional_days>
<cpu_scheduling_period_minutes>60</cpu_scheduling_period_minutes>
<disk_max_used_gb>10</disk_max_used_gb>
<suspend_if_no_recent_input>0</suspend_if_no_recent_input>
<run_if_user_active>0</run_if_user_active>
<max_ncpus_pct>100</max_ncpus_pct>
<vm_max_used_pct>75</vm_max_used_pct>
</global_preferences>




cat global_prefs_override.xml
<global_preferences>
<run_on_batteries>0</run_on_batteries>
<run_if_user_active>0</run_if_user_active>
<run_gpu_if_user_active>0</run_gpu_if_user_active>
<idle_time_to_run>1.000000</idle_time_to_run>
<suspend_cpu_usage>25.000000</suspend_cpu_usage>
<start_hour>0.000000</start_hour>
<end_hour>0.000000</end_hour>
<net_start_hour>0.000000</net_start_hour>
<net_end_hour>0.000000</net_end_hour>
<leave_apps_in_memory>0</leave_apps_in_memory>
<confirm_before_connecting>1</confirm_before_connecting>
<hangup_if_dialed>0</hangup_if_dialed>
<dont_verify_images>0</dont_verify_images>
<work_buf_min_days>1.000000</work_buf_min_days>
<work_buf_additional_days>5.000000</work_buf_additional_days>
<max_ncpus_pct>0.000000</max_ncpus_pct>
<cpu_scheduling_period_minutes>120.000000</cpu_scheduling_period_minutes>
<disk_interval>60.000000</disk_interval>
<disk_max_used_gb>10.000000</disk_max_used_gb>
<disk_max_used_pct>50.000000</disk_max_used_pct>
<disk_min_free_gb>1.000000</disk_min_free_gb>
<vm_max_used_pct>75.000000</vm_max_used_pct>
<ram_max_used_busy_pct>50.000000</ram_max_used_busy_pct>
<ram_max_used_idle_pct>90.000000</ram_max_used_idle_pct>
<max_bytes_sec_up>0.000000</max_bytes_sec_up>
<max_bytes_sec_down>0.000000</max_bytes_sec_down>
<cpu_usage_limit>100.000000</cpu_usage_limit>
<daily_xfer_limit_mb>0.000000</daily_xfer_limit_mb>
<daily_xfer_period_days>0</daily_xfer_period_days>
</global_preferences>
Gundolf Jahn
 
BAM!ID: 16586
Joined: 2007-01-07
Posts: 469
Credits: 447,470
World-rank: 313,722

2012-12-31 14:37:13

mercury1981 wrote:

  1. After booting BOINC Manager does not recognize my Geforce 560 Ti - only if I stop BOINC service manually and start it again the GPU is available.


That might be caused by BOINC starting too early (before the graphic system has been initialized). Try rearranging the startup procedures and/or inserting sleep commands.

Gruß,
Gundolf
andreasschachl
BAM!ID: 18999
Joined: 2007-02-10
Posts: 4
Credits: 928,990
World-rank: 209,969

2013-01-01 11:24:49

Hi!

Thank you for your reply: Can you point me where I can configure that? I tried to insert a "sleep" in the /etc/init.d/boinc-client script - that solved the problem for BOINC but now I need 2 tries to login using GDM and I can see in the background that there are some weird signs in the background.

Where else could I add such sleeps?

Thank you!
Gundolf Jahn
 
BAM!ID: 16586
Joined: 2007-01-07
Posts: 469
Credits: 447,470
World-rank: 313,722

2013-01-01 12:41:46

Sorry, but I'm no (longer a) unix guy. However, I think that you are at the right place with the init.d script. I'm not sure where I've read about it, but you might find answers at the BOINC Message boards.

Gruß,
Gundolf
SubNuke
 
BAM!ID: 17642
Joined: 2007-01-22
Posts: 28
Credits: 3,534,761,692
World-rank: 603

2013-01-01 16:27:32
last modified: 2013-01-01 16:52:28

mercury1981 wrote:
Hi!

Hi!

Can you point me where I can configure that?

Perhaps. I will try.

I tried to insert a "sleep" in the /etc/init.d/boinc-client script - that solved the problem for BOINC but now I need 2 tries to login using GDM and I can see in the background that there are some weird signs in the background.

I agree that you seem to be on the right track and very close. I cannot say whether the interference with GDM is related to your modification of /etc/init.d/boinc-client script, however, I took a related but very slightly different approach on my Fedora and CentOS systems.

Where else could I add such sleeps?

I added the following line to /etc/rc.d/rc.local:

echo "service boinc-client restart" | at now + 1 minutes

As you can see, instead of sleep, wait, or delay, this merely restarts the BOINC client daemon after the GPU's (video cards) have been fully initialized.

Thank you!

You're welcome!

If you report back whether this works for you, then this thread may be helpful to others who search for a solution to this issue in the future.

-|- Regards,
(_) SubNuke
andreasschachl
BAM!ID: 18999
Joined: 2007-02-10
Posts: 4
Credits: 928,990
World-rank: 209,969

2013-01-02 10:24:53

Hi SubNuke!

Thanks a lot - that solved the problem with not usable GPU!

Btw. in Ubuntu it is /etc/rc.local file where I added the line and not /etc/rc.d/rc.local

Thanks again!
andreasschachl
BAM!ID: 18999
Joined: 2007-02-10
Posts: 4
Credits: 928,990
World-rank: 209,969

2013-01-12 08:20:34

Hi!

Just in case somebody is interested - I found a workaround for the idle-detection problem:

I'm using Gnome-screensaver to trigger starting / stopping of BOINC service:

Step 1: Create a file and make it executeable:
Step 2: use the following command to hook to gnome-screensaver in order to start / stop BOINC service

Code:
dbus-monitor --session "type='signal',interface='org.gnome.ScreenSaver'" | ( while true; do read X; if echo $X | grep "boolean true" &> /dev/null; then sudo service boinc-client start; elif echo $X | grep "boolean false" &> /dev/null; then sudo service boinc-client stop; fi done )


Step 3: disable password prompt for "sudo" by adding the following line to /etc/sudoers

Code:
your_username ALL=(ALL) NOPASSWD: ALL


Step 4: start BOINC-Manager and set it to "run always"
Step 5: add your created script-file to your auto-start scripts in gnome
Step 6: restart your PC and check if everything works as expected :-)
Pages: [1]

Index :: BOINC :: Problems with BOINC under Linux / Ubuntu 12.04 (BOINC 7.0.27 / 42)
Reason: