Pages: [1]
Guest

2006-03-09 05:51:12
last modified: 2006-03-09 05:58:26

Hi,

Quick question: This is something I’ve noticed in BOINC, and I find it a bit aggravating. When a work unit for any project (SETI, Einstein, SIMAP, Malaria, SZTAKI, FAAH, and LHC), on both Windows and Linux, hits about 98% complete or hits the two minutes left mark, it downloads a new work unit (if available), and then switches to another project. When it cycles through the projects, it will go back to the original, finish it, and then go to the new work unit. I have not noticed this on my Mac yet, but only three of the above projects are able to run on that. The timeslice period for all my projects is set to four hours instead of one, so it’s not nearing the end of a timeslice.

At any given time, I will have one or two (occasionally three) work units for different projects that each have less than two minutes work left, but are sitting pending. Sometimes, time permitting, I’ll suspend the other work units and flush out the nearly-complete ones.

Is there a way to prevent this, and have it finish work units that are so close to completion? For the projects where I only get one WU done a day, it’s a bit frustrating to see something so close that will sit another 12 or 16 hours before being sent in.

Thank you for any advice.

[Edit] Oh, yes. I'm running BOINC 5.2.13, on all three OS'es. The Windows PC is Win XP SP2, fully patched, with 1Gb of ECC RAM. The Linux PC is Fedora Core 4, fully patched with latest kernel (from "up2date" command), with 384Mb non-ECC RAM. The Mac is running OS 10.4, latest and fully patched, with 768Mb RAM. All applications write to disk when switching. No other instability or undesirable behavior noted, and no errors are produced.
Guest

2006-03-27 03:35:43


Is there a way to prevent this, and have it finish work units that are so close to completion? For the projects where I only get one WU done a day, it’s a bit frustrating to see something so close that will sit another 12 or 16 hours before being sent in.


I think I solved my own problem.

When SZTAKI went past dimension 12 and was using an non-optomized client, the WU's had predicted times of under two hours, but were taking 6-8 hours on an Athlon XP 3200+. Unfortunately, because of the predicted time, my three computers were downloading what ended up being several days worth of work at a time, and it was expiring. I had to stop it alltogether on my Apple G4 500MHz, because each WU was about 16 hours.

So, to attempt to compensate, I changed the "Connect to network every" from the default 0.1 to 0.01. I figured it would only download one WU at a time.

Well, this setting propogated to all my projects. At that point, it started halting any WU for any project when it hit about two minutes or about 98%, and switching projects.

When SZTAKI recently got back under controll, I went in to change this, and found it propogated. (I've only been using BOINC since December.) After I set all my projects back to 0.1 days and updated all on each platform, the problem simply stopped. Everything is back to normal now.

I'm just throwing this out there in case anyone else stumbles into this.
Lee Carre
 
BAM!ID: 41
Joined: 2006-04-19
Posts: 262
Credits: 299,581
World-rank: 394,422

2006-03-29 13:51:17
last modified: 2006-03-29 13:53:05

When a work unit for any project (SETI, Einstein, SIMAP, Malaria, SZTAKI, FAAH, and LHC), on both Windows and Linux, hits about 98% complete or hits the two minutes left mark, it downloads a new work unit (if available), and then switches to another project.
that's because your preferences say that boinc should download a new unit at that time, if you want it to do things differently you might want to adjust your "connect to network" preference
the reason it switches, it because a "check" is done on virtually any operation (update, download etc.) and when it checked, the other project had the most debt, so it started crunching that one instead

the author of the work scheduler is addressing this "excessive switching" issue (quite a problem on multiCPU machines, as it "checks" everytime i unit finishes, so the actual switch time can end up being minutes rather than hours) and other stupid things the core client does, and hopefully at least a few of the problems will be resolved eventually (maybe even in the 5.4 versions)

Is there a way to prevent this, and have it finish work units that are so close to completion? For the projects where I only get one WU done a day, it’s a bit frustrating to see something so close that will sit another 12 or 16 hours before being sent in.
adjust your cache is basically the answer
Want to search the BOINC Wiki, BOINCstats, or various BOINC forums from within firefox? Try the BOINC related Firefox Search Plugins
Pages: [1]

Index :: BOINC :: Boinc Manager Question
Reason: